CodeSVby CA Technologies

Supported Environments

< Back

Supported Operating Systems

  • Microsoft Windows 7 and later (32bit, 64bit)
  • MacOS 10.12 “Sierra” and later (64bit)
  • RedHat Enterprise Linux 6 and later (32bit, 64bit)
  • Ubuntu 14.04 and later (32bit, 64bit)

Other operating systems supporting Oracle Java SE Development Kit should work as well.

Required Java Version

Oracle Java SE Development Kit 7 or 8 (JDK)

Java 3rd Party Dependencies

Group

Name

Supported Versions

Project URL

com.google.guava guava 20.0 and later https://github.com/google/guava/
com.jayway.jsonpath json-path 2.2.0 and later https://github.com/jayway/JsonPath
commons-codec commons-codec 1.4 and later http://commons.apache.org/codec/
commons-io commons-io 2.4 and later http://commons.apache.org/io/
javax.servlet javax.servlet-api 3.1 https://glassfish.dev.java.net
junit junit 4.x and later http://junit.org
net.minidev accessors-smart 1.1 and later http://www.minidev.net/
net.minidev json-smart 2.2.1 and later http://www.minidev.net/
org.eclipse.jetty jetty-* 9.2.x, 9.3.x, 9.4.x http://www.eclipse.org/jetty
org.hamcrest hamcrest-* 1.3 http://hamcrest.org/JavaHamcrest/
org.javassist javassist 3.21.0-GA and later http://www.javassist.org/
org.json json 20170516 and later https://github.com/douglascrockford/JSON-java
org.ow2.asm asm 5.0.x and later http://asm.objectweb.org
org.slf4j slf4j-api 1.7.x and later https://www.slf4j.org/